- Paligo Documentation
- Quick Start
- Paligo Interfaces
- Next-Gen Editor
Paligo Interfaces
Next-Gen Editor
Introducing the Next-Gen Editor, a powerful tool crafted specifically for professional tech writers seeking a seamless and intuitive writing experience. This new editor offers a user interface that closely resembles other writing platforms, providing a familiar workspace that promotes productivity and ease of use. Its clean design ensures that focus remains on content creation, while advanced features support complex workflows and collaboration.
Despite its familiar appearance, the underlying structure is still the same robust XML-based architecture. Writers can take advantage of the rich semantic capabilities of DocBook, making it possible to organize, reuse, and adapt content efficiently across different projects and platforms.
The Next-Gen Editor is designed with flexibility in mind, allowing for both simple editing tasks and complex document management. This integration of a familiar interface with a solid XML backbone aims to elevate professional writing workflows and streamline content management processes.
Learn more about the Next-Gen Editor:
Interface overview
The Next-Gen Editor interface is divided into four main sections:

Editor header
The Editor header shows different information depending on whether or not a component is open for editing.
It contains, among other things the component name, as well as the Menubar, the Toolbar and the Element structure menu. It also show the save status of the component in question.

Component name
Save status indicator
Menubar
Toolbar
Element structure menu
Document search
NoteDocument search is only available when in Read-only mode, not in Edit mode.
Editor settings
Mode switcher
Content structure pane
The Content structure pane provides an easily accessible overview of all components that are used in the current document, and allows you to easily navigate to those individual components.

Component name
Reused and structure reused components
Editing area
The Editing area is where you will do most of your work. Here you will write your content, add images, and reuse other components.
The Editing area is meant to be used as a regular document editor, but the underlying structure is still DocBook XML. It gives you an easy way to access all elements, formatting options and components you will need to write your documentation.
See also Edit components for more information about editing components.

Component name
Status indicator (only appears when the status is not Work in progress)
User currently editing the document
Edit/Close edit button
More options menu
Set to Work in progress button (only appears when the status is not Work in progress)
Title element
Currently selected element
AI Assistant button
Reused component
Component section (structure reuse component)
NoteNote that components that have been inserted as structure reuse can be edited in place, while regular reused components (such as number 6), need to be opened in a separate tab in order to edit them.
Edit/Close edit button
Side pane
The Side pane contains both the widgets used to enhance your document, as well as the comments left by authors, contributors and reviewers.
Element attributes panel
The Element attributes panel shows the attributes that are in place for the currently selected element. It is used to add, remove, edit and profile / filter an attribute and set its value.
Each element, such as a para, has its own properties, which are called attributes. When you add an attribute to an element and set its value, it only affects the specific element you selected. For example, if you add a filter element such as xinfo:country to a paragraph, it only applies to that paragraph and will not affect any other para elements.
It is only possible to choose attributes that are valid for the type of element selected, for example, an imagedata element can have a width attribute. By adjusting the value of the width attribute, the size of the image is set. By using a percent sign (%) after the value, the image can be scaled. A width attribute cannot be set on a para element.
XML tree view panel
The XML tree view shows the structure of the topic that you have open in the main Paligo editor. For writers, it is especially useful as it means you can see the elements you have in place all at once, and it also makes it much easier to move blocks of content to new positions. You can drag an element from one (valid) position in the XML tree to another and your topic will update automatically to match. It is also possible to select and move multiple blocks at once by selecting while holding CMD (Mac) or CTRL (Windows).
Reuse text panel
The Reuse Text panel is where you can search for existing text fragments in the database. If you are writing a paragraph or an instruction that you think may exist, you can search for it and reuse the existing version. Rather than repeatedly recreating recurring phrases, you write it once and reuse it wherever needed. Then, if the text ever needs to change, you can make the change once and it will apply to every instance automatically. To learn more, see Find Reusable Content and Reuse Text Fragments.
When a term is entered in the search field, a list of exact and close matches is presented in the Reuse Text panel. You can insert a match or access information about it via the cog icon. To the right of each match, the xml id is shown.
Documentation panel
The Documentation panel provides information about the currently selected element. It shows a list of Common Attributes that are often used with that element, with a brief description of each attribute. There is also a Description of the selected element, which is shown at the bottom of the documentation section.
Validation panel
Your content is automatically validated by Paligo before it is saved to the database. You can turn this feature on and off, see Turn Validation On or Off. It is also possible to validate the content manually, see Validate Content Manually.
If your content have broken any of the Validation Rules, Paligo displays an error message and adds a red highlight to the element. The Validation Panel provides information about the error to help you solve it, see Invalid Content.
Metadata panel
The Metadata panel shows all the metadata associated with the current document. Additionally, it shows where the current component is used, as well as which taxonomies have been applied to it.
Enable the Next-Gen Editor
The Next-Gen Editor is not enabled by default, and needs to be enabled by an administrator. Individual users can then choose to set it as their default editor. To enable the Next-Gen Editor:
Sign in to Paligo using a user account that has administrator permissions.
Select the avatar in the top-right corner.

Select Settings from the menu.

Select the System Settings tab.

In the Editor Light (beta) field, select the type of user that should have access to the Next-Gen Editor in the dropdown:
Disabled: Next-Gen Editor is disabled for all users.
Admin users only: Next-Gen Editor is enabled for users with administrator privileges.
All authors: Next-Gen Editor is enabled for all users of this instance.
To set the Next-Gen Editor as your default editor, please see Editor settings.
Edit components
When you open a component in the NGE, it will always open in Read-only mode. In order to start editing a component, you need to set the component to Edit mode, after which you can edit as usual.
If for any reason the Next-Gen Editor encounters unsupported XML structures (for example, when changes have been made in the source code editor), Paligo will auto-repair these before you can edit the content.
Start editing
When you open a component in the Next-Gen Editor it will open directly in edit mode if the status of the component is set to Work in progress. If the status is not Work in progress (e.g. In translation), you can set that status to enable editing by selecting the Set to work in progress button.
When the status has been changed to Work in progress, select the Edit/Close edit button to start editing.
By default, Autosave will be enabled for all users. If users decide to turn off Autosave, that setting will be remembered by the Next-Gen Editor.
Select the Edit/Close edit button
.
NoteMake sure you are in Edit mode, and not suggestion mode by using the Mode switcher
.
Once you are done with your edits, select the Edit/Close edit button again
.
NoteIf you have unsaved changes in your document, you will get a save warning when exiting edit mode.
Insert new elements
Blank topics by default start with an empty title element and an empty para element. There are several ways to insert new elements into a component:
using the Enter key (
paraonly) and convertingusing the Insert menu
using the Element structure menu
using the Insert paragraph button
Insert element using the Insert point
The Insert point is the easiest way to add elements to your document. The Insert point is a graphical interface element represented by a dotted line with a plus that can be accessed both by using the cursor, as well as by keyboard navigation.

The Insert point
In order to make it clear where exactly in the element structure you are placing your new element, the Selection highlight will appear, indicating the level at which you are placing the element within the structure. For example, if you want to add an item to an itemizedlist element, rather than adding a para to an existing list item, you would select the Insert point directly inside the itemizedlist element instead of inside the listitem element.

Insert point inside the itemizedlist (1) vs inside the listitem element
If the Insert point is not located inside another element (e.g. when inserting a para in the main section of the topic), the Selection highlight will not appear.
If the Insert point is not visible in the Editing area, do the following:
Select View in the Menubar
Check the Insert point checkbox
In any component (topic, informal topic etc.), hover your cursor over the content. The Insert point will appear between elements.
NoteThe Insert point will not appear in Structure view (e.g. when viewing the structure of a publication).
Select the plus icon in the Insert point
.
Select the element you want to insert from the Element insert menu.
Place your cursor anywhere in your document.
Use the up- and down arrow keys (↑, ↓) to navigate up and down the document. When the cursor reached the beginning or end of an element, it will jump to the next Insert point upon the next press.
Select Enter.
Use the up- and down arrow keys to scroll down the list of elements in the Element insert menu until you reach the element you want to insert.
Select Enter.
Insert element using Enter
In most cases, pressing Enter inside an element will produce a new paragraph (an exception to this is list items, in which case pressing Enter will result in a new list item or procedure step; see Lists). You can then convert that paragraph to other valid elements (see Convert an element).
Place your cursor at the end of an element.
Press Enter.
With the cursor inside the new paragraph, either use the Element insert menu or the Element context menu to convert the paragraph to another valid element.
Insert paragraph before or after block elements
In cases where it is not possible to put your cursor at the end of the element in order to insert a new element (i.e. block elements such as images, tables and reused components), the Next-Gen Editor provides buttons at the top and bottom of the element to insert an empty paragraph before or after the element, respectively.
You can also right-click on block elements, then select Insert before or Insert after.
To insert an empty paragraph after a block element:
Hover over the element you want to place an element after.
Select the Insert paragraph button
, either at the top or the bottom of the element. A new paragraph will be created.
NoteThe newly created paragraph can be converted to another element if you need a different element. Please see Convert an element for more information on converting elements.
NoteInserting paragraphs using the Insert paragraph button also works for subsections (such as reused topics).
Insert additional sections
If you want to insert additional sections before of after an existing section, you can use the Insert section button 
Insert elements using the Insert menu
You can use the Insert menu to insert valid elements into your component.
Place your cursor at the end of an element or inside an empty paragraph.
NoteSelecting a block element (e.g. table or image) when the cursor is placed inside an empty paragraph, will convert that paragraph to the chosen element.
Choose a valid element from the insert menu.
NoteInvalid elements will be greyed out and can not be chosen at your current cursor position.
NoteThe Insert menu contains both block- and inline elements. When choosing an inline element (such as Variable, or Inline image), the new element will be placed inline rather than a new block element being created.
Insert element using the Element structure menu
The Element structure menu lets you insert elements before or after your currently selected element.
Place your cursor inside an element before or after which you want to insert a new element.
Select the element in the Element structure menu.
NoteDepending on the element chosen, as well as on which new element you want to insert, you may have to select the parent element of the currently chosen element. For example, if you have a procedure and you want to insert a step after the current step, you have to select the step element, rather than the para element of that step.
Select Insert element > Before element/After element.
NoteDepending on the element, you can also choose As first child or As last child, but this will place the (inline) element inside the current element, rather than creating an entirely new element.
Select a valid element you want to insert.
Insert (reused) components
Inserting components (both topics, as well as informal topics) works in much the same way as inserting other (block) elements.
Place your cursor at the end of a paragraph, or inside an empty paragraph. Create a new paragraph if necessary.
NoteInserting a component with your cursor placed inside an existing paragraph (i.e. not at the beginning or end of the paragraph) will result in the existing paragraph being split into two separate ones, with the inserted component in between.
Select the Element insert menu, then select Component.
When reusing informal topics as parts of lists and procedures (see Reuse a Sequence of List Items), the reused topic needs to be placed before or after the step element. For more information, please see Lists).
Reused component options
You can manage reused components inside topics by accessing the More options menu at the top right of the reused element.
Here you can do the following:
Hide/Show: toggles the accordion to hide or show the reused component's contents.
Detach reuse: converts the reused component into a regular section and severs the link to the original component.
Reload: reloads the reused component (e.g. when you've altered the reused component in another browser tab.
Copy UUID: copies the reused component's UUID to the clipboard.
Delete: deletes the reused component from the topic.
Insert a reusable text fragment
Every paragraph (or other textual block element, such as titles and captions) that you write in Paligo is stored in the database and is available for reuse. Reusable paragraphs are also known as reusable text fragments. By reusing paragraphs, you can save time with content creation and updating and make your content more consistent.
For information on how to insert reusable text fragments, see Insert Reusable Text Fragment.
When inserting reusable text fragments it is important to set the insertion point (cursor) inside an empty paragraph or list item. If the element is not empty, you will be asked if you wish to replace the current element with the text fragment you are trying to insert.
Insert inline elements
Inserting inline elements is done in much the same way as it was before.
Place your cursor where you want to insert the inline element or select the text you want to apply the element to.
Choose the inline element by:
Selecting the Insert menu and choosing from there.
Using the Element context menu (Alt + Enter ⏎ (Windows) or Command ⌘ + Enter ⏎ (Mac))
Element context menu favorites and commonly used elements
The top part of the Element context menu consists of two sections: Favorites and Commonly used. The Commonly used section is populated automatically with the five elements you use most often. The Favorites section is populated by you.
Add favorites
Access the Element context menu ((Alt + Enter ⏎ (Windows) or Command ⌘ + Enter ⏎ (Mac))
Select the star icon next to the element you want to favorite.
NoteThe element will appear in the Favorites section the next time you open the Element context menu.
Remove favorites
Removing favorites is done in much the same way as adding them. Just select the star icon next to the element you want to remove from the Favorites section.
Convert an element
Empty paragraphs can easily be converted to other types of elements.
Create an empty paragraph.
With the cursor inside the paragraph, select the Element insert menu, then choose the element you want to convert it to (e.g. a table).
NoteTo convert a paragraph to a list (ordered, unordered, procedure etc.), select the appropriate button in the toolbar.
Note that lists can also be converted from one type to another by placing the cursor inside the list or nested list and selecting the button in the toolbar for the list type you want to convert to.
Advanced View
The Advanced View gives you additional editing options by replacing the standard system-related right-click menu with Paligo's own context menu. It is intended for authoring complex DocBook structures and is recommended for users who are familiar with DocBook syntax.
To enable Advanced View:
In the Menubar, select View.
Select Advanced View
Check the box to enable Advanced View.
Clear the box to revert to the regular (system) context menu.
Edit elements
This page provides guidance on working with specific elements in components.
General formatting
There are two main ways to work with formatting:
the Format menu in the Menubar.

the Toolbar.
NoteNote that the Toolbar also contains other options, such as inserting sections, saving, and spellcheck.
Both these methods work in the same way.
Select the text you want to format.
NoteYou can also place the cursor anywhere inside an element to produce an empty (formatted) element.
Choose your formatting option from either the Format menu or one of the icons in the Toolbar.
For an overview of the various icons and keyboard shortcuts used for formatting and other functions, please refer to the Icons and keyboard shortcuts page.
Tables
While it is still possible to adjust tables and cells by setting attributes on individual table elements, the easiest and fastest way to work with tables is to use the Table toolbar.
Column options
Row options
Cell properties
Merge cells
Merge cell options
Toggle caption
Table properties
Delete
Columns (1)
Place your cursor in any cell in the column you want to affect.
From the Table toolbar select the Column button (1).
In the dropdown you can choose from the following options:
Header column (toggles header column on and off)
Select column (to select the entire column)
Insert column left
Insert column right
Delete column
Rows (2)
Place your cursor in any cell in the row you want to affect.
From the Table toolbar select the Row button (2).
In the dropdown you can choose from the following options:
Header row (toggles header row on and off)
Select row (to select the entire row)
Insert row above
Insert column below
Delete row
Cell properties (3)
Here you can set properties such as text alignment for individual cells.
Place your cursor in the cell you want to affect.
From the Table toolbar select the Cell properties button (5).
In the dialog box you can choose from the following options:
Horizontal text alignment
NoteText alignment for an entire column can be set in the Table properties dialog (7), but note that alignment set on individual cells will always take precedence over entire column alignment settings.
Vertical text alignment
Merge cells (4 and 5)
Place your cursor in the cell you want to affect.
From the Table toolbar select the Row button (5).
In the dropdown you can choose from the following options:
NoteDepending on your cursor placement, one or more options may not be available for that particular cell.
Merge cell up
Merge cell down
Merge cell left
Merge cell right
Split cell vertically
Split cell horizontally
Merge cells button (4)
If you have multiple cells selected, you can use the Merge cells button to merge them. Note that this button will be unavailable if only one cell is selected.
Table captions
Toggle the table caption on or off.
Place your cursor anywhere inside your table.
From the Table toolbar select the Toggle caption button (6).
Select the button again to turn the caption off.
Table properties (7)
In the table properties you can set both the width of the table, as well as individual column widths and horizontal text alignment for entire columns.
Place your cursor anywhere inside your table.
From the Table toolbar select the Table properties button (7).
Set the table width in the Width field.
NoteOnly percentages can be used for the table width. Note that the width has to be set from 1 to 100.
Set the column width for individual columns. The Total width field will indicate the aggregate of the values set for all columns together.
NoteOnly percentages can be used for the column width. Note that the width has to be set from 1 to 100.
NoteAny columns that have not been assigned a width will have their widths set automatically and evenly to the remaining space. E.g. if you have a table with three columns and one is set to 50%, the remaining two will each have a width of 25%.
NoteIf the Total width exceeds 100%, the configuration cannot be saved.
Delete table (8)
Place your cursor anywhere inside your table.
From the Table toolbar select the Delete button (8).
Images
The easiest way to adjust image properties is by using the Image toolbar. You can also set image properties by assigning attributes to image elements.
Replace an image
To replace an image with another image:
Select the image.
From the Image toolbar select the File browser icon (1) to open the Image file browser
Browse to the desired image or upload a new image and select it.
Edit image details
Select the image.
From the Image toolbar select the Edit image details icon (2) to show the image details window.
In the image details window you can:
Edit the title
Select the language variants
Update the image description
Replace the image with an existing image, or upload a new image.

Open image location
The Open image location function lets you open the image's parent folder in a separate browser tab.
Select the image.
From the Image toolbar select the Open location in new tab icon (3).
A new browser tab opens showing the contents of the image's parent folder in the Content manager.
Image caption
Select the image.
From the Image toolbar select the Toggle caption icon (4) to toggle the image caption on or off.
'Switch between Image and inline image
You can toggle between Image and Inline image.
Select the image.
From the Image toolbar select the Image/Inline image dropdown (5) and select Image or Inline image.
Image width
Select the image.
From the Image toolbar select the Image width field (6) and enter the image width.
From the Image toolbar select the Unit field (7) and set it to either percentage (%) or pixels (px).
Delete image
Select the image.
From the Image toolbar select the Delete icon (8).
Links and cross-references
Inserting links can be done via the Insert menu in the Menubar.
Place your cursor where you want to insert the link, or select existing text you want to use as the link text.
From the Menubar select Link, then select Cross reference or External link.
Lists
Working with lists works in much the same way as in other writing programs. Most of the actions required can be performed through the keyboard.
Create a list
Create a new paragraph
Convert the new paragraph to a list by:
using one of the list icons in the Toolbar
using the Element context menu and search for the list type you want, e.g. itemizedlist, orderedlist, or ptocedure.
Nested lists
Nested lists are made by adding a regular list item, and then indenting that item to create a nested list.
Place your cursor at the end of the list item you want to create a nested list for.
Press Enter.
Convert the newly created list item into a nested list by:
pressing the Tab key.
from the Toolbar select More options, then Indent list item
NoteIf the nested list is not of the correct type, place your cursor in any of the list items of the nested list and use the list item icon in the Toolbar to convert the nested list.
NoteYou can outdent a nested list item by placing the cursor anywhere in the list item you want to outdent, and then:
pressing Shift + Tab.
from the Toolbar select More options, then Outdent list item
Reuse list items
In technical publications, it is quite common to have list items and steps that are repeated in various different topics. For example, if you are documenting software, it is likely that you will use a 'Save' step in lots of different procedures.
In Paligo, there are two different ways to reuse steps. You can use:
The reuse text feature for single list items or steps.
An informal topic to reuse a sequence of list items or steps.
Reuse single list items or steps
Insert a new empty list item.
Using the Reuse text widget, search for and insert the text you want to use as the list item.
NoteFor more information on usin the Reuse text feature, see Insert Reusable Text Fragment.
Reuse a sequence of list items or steps
When reusing a sequence of list items or steps, it is important to place the reused informal topic in the correct position in the structure to avoid creating invalid XML structures. The informal topic containing the reused items/steps should be placed before or after a lit item or step, not after the paragraph inside a list item or step.
Place the cursor anywhere inside the list item before or after which you want to insert the informal topic.
In the Element context menu, select the
listitemelement (not theparaelement inside thelistelement) and choose Insert element > Insert before or Insert after.In the Element insert menu, select
parato insert an ampty paragraph.With the cursor inside the newly created empty paragraph, from the Menubar select Insert and then Component.
In the Import content window, select the informal topic you want to insert.
Editor settings
The Editor Settings are global for the Next-Gen Editor and will apply to all the topics and publications you work with. However, the settings will only be applied to your user account. Other Paligo users can set up their own preferences.
Control which elements gets automatic IDs from Paligo, see Global. Change the color scheme for the source code editor, see Source code editor. Select math editor, see Editing. Enable or disable automatic validation against the three different sets of validation rules, see General.
General
Under the General tab you will find settings for both Paligo as well as Schematron validation.
Paligo can check that your content is valid either manually or before the topic is saved to the database. But these checks will only take place if one or more of the validation features are turned on for your topics.
To turn validation on or off and choose which rules are used:
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the General tab.
Set your validation rules In the Documentation Validation section.
You can choose from two validation schemas:
For each type of validation you can select:
Validate on save: to turn the type of validation on whensaving a topic. Paligo will test that your content complies with the selected rules whenever you try to save a topic. Clear the box to turn the validation off when saving a topic.
Validate on demand: to use that type of validation when youValidate Content Manually. Paligo will test whether your content complies with the selected rules whenever you use the validate option in the Editor's toolbar. Clear the box to turn the validation off.
Select Save settings
Although you can choose to turn off validation, we strongly recommend that you have Paligo XML schema validation enabled as this will prevent you from saving invalid content. Paligo can only publish content that has a valid structure.
Editing
Here you can set your autosave and MathType settings.
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Editing tab.
Turn autosave on or off using the toggle button.
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Editing tab.
Turn MathType editor on or off using the toggle button.
Select Save settings.
Preview
You can generate a preview of the content as PDF, HTML or HTML5 from the Toolbar. For example, you can preview it both as HTML5 and PDF output.
The preview initially uses the default layouts for each type of output and might differ from your customized layout. But you can set Paligo to use your customized layouts instead. This will give you a preview that is closer to how your content will look when you publish it using your own layouts.
To choose the layouts that are used for your previews:
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Preview tab.
Select all the settings for your preview using the dropdowns for the following preview types:
PDF preview layouts
HTML preview layouts
HTML5 preview layouts
Select Save settings.
Source code editor
By default, the Source Code Editor uses theMonokaitheme, a dark theme easy on the eyes. It has a black background with cerise, green, yellow and white color-coding for the XML elements, attributes and values.
You can set the source code editor to use a different theme. For example, the Chrome theme has a white background with red, blue, cerise and black color-coding.
But you can use any of a number of themes for the look and feel of the Source Code Editor, whatever is more comfortable for you. Just click the cog wheel icon in the toolbar, and select Code Editor.
To change the theme for the source code editor:
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Source code editor tab.
Select a theme from the dropdown menu in the Theme for the code editor section.
Select Save settings.
Global
Under the Global tab, you can control which elements automatically should get ID attributes assigned to them.
To autogenerate IDs for specific elements:
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Global tab.
Enter the name of the element you want to autogenerate IDs for in the textfield. Multiple element names should be separated by a space.
Next-Gen Editor
Here you can set whether the Next-Gen Editor is used as the default editor.
To enable or disable the Next-Gen Editor as your default editor:
Select the Editor settings button
.
Paligo displays the Editor Settings dialog.
Select the Next-Gen Editor tab.
Toggle the Use Next-Gen Editor switch on or off.
Select Save settings.
If you have set the Next-Gen Editoras your default editor, clicking on a publication in the Content managerwill open the publication in topic view, not structure view. In order to view and manipulate the publication's structure, select More options (…) and then Edit > Open structure.
If you choose not to set the Next-Gen Editoras your default editor, you can open topics in the Next-Gen Editorby selecting More options (…), then Edit >Next-Gen Editor
AI Assistant in the Next-Gen Editor
The AI Assistant integrated into the Next-Gen Editor is designed to help you be more productive in your authoring and provide support across various tasks. Leveraging advanced natural language processing and machine learning algorithms, the assistant can understand user queries, generate content, and offer context-aware suggestions.
Among other things, the AI Assistant can help you refine text, generate content, or transform a regular paragraph into a correctly worded and formatted procedure. By design, the AI Assistant's interactions are confined to the paragraph you are currently working on, so that the overall structure of your topic remains unaltered.
Prompt the AI Assistant
The AI Assistant behaves differently depending on what is selected. If the cursor is placed in an empty paragraph, the AI Assistant will allow you to enter a prompt to generate content. However, if the cursor is placed in a paragraph with existing content, it will instead help you to refine, rephrase or convert the existing content.
Generate content
The AI Assistant allows you to use natural language prompt to generate content in your component. For example, you can ask it to come up with a specific warning, or an introductory paragraph on the product you are working on.
Create a new
paraor place your cursor in an existing emptypara.Select the AI Assistant button
to the right of the paragraph.
Write your prompt in the Generate dialog.
NoteThe prompt cannot be longer than 4000 characters.
Select Enter, or select the Generate button
.
Depending on the result, you can either accept, refine, or discard the generated text:
To accept the suggestion, select the Insert button
.
To refine the suggestion, use the prompt field, or the Refine button
. See below for more information.
To reject the suggestion, select the Close button
, then select Discard in the dialog window.
Refine, rephrase or convert content
If you place your cursor inside a paragraph with existing content, or select part of a paragraph, you can refine, rephrase or convert content.
The AI Assistant will only work on the selected text. If you only place your cursor inside a paragraph, the entire paragraph text will be used as context for the AI Assistant. Since the AI Assistant will convert any selection to a standalone text (even when only part of a sentence is selected), we recommend selecting at least an entire sentence.
Place your cursor inside an existing paragraph, or select some text.
Select the Generate with AI button to the right of the paragraph.
In the refine menu box either:
Enter a natural language prompt to refine your existing content (e.g. “Add an introductory sentence at the beginning”, or “Rewrite this for. more technical audience”).
Use the predefined refinement options by selecting one of them. For more information on the various options, please see the AI Assistant command overview.
Depending on the result, you can either accept, refine, or discard the generated text:
To accept the suggestion, select the Insert button
.
To refine the suggestion, use the prompt field, or the Refine button
. See below for more information.
To reject the suggestion, select the Close button
, then select Discard in the dialog window.
Refine suggestions
Whatever the AI Assistant suggests, you can always change or refine it before you insert it into your component.
Generate a suggestion with the AI Assistant.
In the response dialog either:
Enter a natural language prompt in the prompt field.
Use the predefined refinement options by selecting one of them using the Refine button. For more information on the various options, please see the AI Assistant command overview.
AI Assistant command overview
The AI Assistant has a number of pre-defined commands that allow you to refine or convert existing text. These coimmands can be run when users access the AI Assistant existing text selected.
Improve writing
Helps you reword your text, as well correct grammatical mistakes.
Command | Output |
|---|---|
Rephrase | Rewrites the text block, improving clarity and readability. Structure (<para>) remains the same; only content changes. |
Correct grammar | Identical text block with minor string replacements, fixing grammar and spelling. No structural changes are allowed. |
Simplify language | Replaced with simpler words, sentence structure may be simplified, but variables and other inline elements must remain untouched. |
Content generation
Modifies the selected text to make it more concise, or expand upon it.
Command | Output |
|---|---|
Summarize | The AI Assistant condenses the selected text to one paragraph. Inline tags (bold/italics) from the source are usually discarded unless specifically requested to be kept. Grammar and spelling are also corrected. |
Shorten | The AI Assistant creates a concise version of the input. It removes redundant words and phrases. Variables, links and UI references are retained if they remain in the shortened text. Grammar and spelling are also corrected. |
Elaborate | The AI Assistant adds sentences to the existing <para>. It may introduce new structure (like splitting one paragraph into two) if the elaboration is long. It will add details, examples or explanations to enhance understanding. Grammar and spelling are also corrected. |
Change tone
Helps you change the tone of voice of your text.
Command | Output |
|---|---|
Professional | The AI Assistant converts the text to formal, objective, standard business language. It uses precise vocabulary. Contractions are not allowed. Grammar and spelling are also corrected. |
Friendly | The AI Assistant converts the text to engaging, warm, and helpful language. Contractions may be used where required. Grammar and spelling are also corrected. |
Neutral | The AI Assistant converts the text using direct, factual language. Sentence structure is kept relatively simple. Grammar and spelling are also corrected. |
Concise | Short sentences and imperative verbs are used. Conditional logic (if/then) is retained. Grammar and spelling are also corrected. |
Convert to
Lets you convert text to different structures.
Command | Output |
|---|---|
Ordered list | Converts text to an ordered list. Grammar and spelling are also corrected. |
Itemized list | Converts text to an unordered list. Grammar and spelling are also corrected. |
Procedure | Converts text to a procedure list. Grammar and spelling are also corrected. |
Table | Generates a table with column- and row count adjusted to the selected text. Grammar and spelling are also corrected. |
AI Assistant operational guardrails
For security and operational reasons, the AI Assistant is limited in its scope and context. These guardrails ensure that the AI Assistant focuses only on what the user actively chooses, without affecting the rest of your documentation.
The following guardrails are in place:
The AI Assistant accepts and generates text only. It cannot analyze, generate, or modify images, videos, charts, or diagrams.
When using the natural language prompt, there is a limit of 4,000 characters per prompt.
The AI Assistant acts only on the active editor content. It cannot upload/read external PDF, Word, or Excel files.
The AI Assistant only knows the context provided in the current prompt and selection. It does not scan the entire document, other open tabs, or linked files or content referenced by cross-references.
The AI Assistant is stateless. It does not remember previous conversations. Its memory will be reset once the dialog is closed.
The AI Assistant cannot verify facts, dates, or technical specifications against a real-time database. The user should verify content before inserting it into the document
In some cases, inline elements will not necessarily be preserved unless explicitly requested. Please see AI Assistant command overview for more information.
Comments
Comments are an integral part of the Next-Gen Editor. They are always accessible in the Side pane, both in Read-only- as well as Edit mode. Having the comments always accessible next to the content greatly improves collaboration on topics. Each comment forms its own conversation thread, consisting of the comment itself and all the replies associated with that comment.
View comments
To view open or resolved comments, do the following:
Open the component in the Next-Gen Editor.
In the Side pane, select the Comments tab.
NoteBy default, the comments pane will open showing the currently open comments. In order to view resolved comments, select the Resolved button
.
Navigate to a particular comment by scrolling, or by selecting the comment in the Editing area.
NoteIn the Editing area text with comments are indicated with yellow highlights.

Text with comment
Navigation
You can navigate the comments pane by scrolling, as well as by selecting the comment in the Editing area. However, for navigating through all of the comments in the list, you can also use the Comment navigation. Use the up and down arrows 
Insert a new comment
Authors, can insert comments to give feedback on content. Topics do not have to be open in Edit mode in order to be able to insert comments.
Open the component in the Next-Gen Editor.
In the Editing area, select the element you want to comment on, or highlight part of the element.
NoteHighlighting part of the content will associate the comment with only the highlighted part (marked in yellow once the comment is inserted). Otherwise the comment will be associated with the entire element.
In the Side pane, select the Comments tab.
Insert a comment by either: or in the .
With the comments pane opened, selecting the Add new comment button
at the top of the Side pane.Selecting the Add new comment button
at the top in the Toolbar.Selecting the element you want to comment on in the Element context menu and then selecting Add comment.
Add your comment in the Comment field, then select Comment.
Edit comments
You can edit your own comments, as well as your own replies to comments.
Navigate to the comment in the Comment Side pane, or by selecting the highlighted comment in the Editing area.
Select More options in the top right of the comment.
From the More options menu, select Edit
.
NoteHere you can also mark a previously read comment as unread, by selecting the Mark as unread option.
Make your edits to the comment text, then select Save
.
Reply to comments
You can reply to other people's comments to elaborate on the feedback given.
Open the comments in the Side pane.
Select the comment you want to reply to.
NoteIf the comment has already been resolved, you will need to [???section-id235379753079021???] it first.
Add your reply in the Reply field, then select Reply
NoteYou can mention other Paligo users by using the @-mention. Type @, then select the name of the user from the list, or type their name. Mentioned users will be notified of the comment by email, and will get a direct link to the comment in question.

If you mention users who do not have access to the component you are commenting on, you will get a warning telling you to provide access for that particular user.
Resolve a comment
Once a comment has been dealt with, it can be set to Resolved to remove it from the list of open comments. After resolving, it can still be viewed by selecting the Resolved button 
In the Side pane, select the Comments tab.
Select the open comment you want to resolve.
Select the Mark comment as resolved button.
NoteYou can also resolve all open comments at once, by selecting the Resolve all open comments button
at the top right of the Side pane.
There may be times where you need to make a change to a resolved comment or need to revert it back to an open comment, in which case, you will need to restore it.
In the Side pane, select the Comments tab, then select the Resolved
button.
Select the comment you want to restore.
Select the Restore comment button.
The comment will now disappear from the Restored list, and can be found in the Open comments list.
Delete a comment
There may sometimes be a need to delete comments entirely.
Deleting comments will remove them completely. Unlike resolved comments, they cannot be restored.
In the Side pane, select the Comments tab, then select the comment you want to delete, either from the Open- or Resolved comments list.
Select the More options
button, then select Delete .
Select Delete
again to confirm.
Review in Next-Gen Editor
When opening a review assignment in the Next-Gen Editor, reviewers get a slimmed down version of the editor that allows them to leave comments on a component's content. Since comments are stored with the component, the original author can then access these comments and incorporate them into the component using the full Next-Gen Editor.
You can only comment on text elements. You cannot comment on images, equations or program listings.
Set profile and variables
If the content you are reviewing has profiles/filters and/or variables applied to it, you may want to set the correct Profile settings so that you can review the content as it is meant to be published.
To configure the Profile settings:
Access the assignment via the link in the mail you received, or via the Dashboard.
Select the Profile settings icon.
The Profile settings dialog opens.
Select the tabs to set:
Variable sets
Profiling
NoteIf you have a set of profile settings saved as Favorite, you can select that from the Favorites tab.
Alternatively, you can apply your variables and profiling settings, then return to the Favorites tab and select New to add the set as a new favorite.
Select Apply.
Compare snapshots
In Review mode, you can compare the current version of the topic to previous versions by comparing snapshots. For more information on snapshots, see Create Snapshot in Resource View.
To compare snapshots:
With the topic opened in Review mode, select the Compare snapshots icon
in the Editor header.
From the dropdown, select the snapshot you want to compare the current topic to.
The topic reopens with all changes made in the topic compared to the chosen snapshot highlighted. Deleted content is indicated in red highlights, while added content is indicated in green highlights.
Insert a comment
Access the assignment via the link in the mail you received, or via the Dashboard.
Place your cursor in the paragraph you want to comment on (to comment on the entire paragraph), or select a specific part of the text.
Start typing your comment.
TipYou can mention other users in your comments and Paligo will send them a notification message.
To mention them, enter @ followed by the first characters of their name. Paligo then displays a list and you can select the user from the list.
Select Comment to save it.
Edit an existing comment
While you can see other reviewers' comments, you can only edit your own comments.
In the Side pane select the comment you want to alter.
TipYou can also navigate through all comments by using the Comment navigation arrows.
Select the More options button
, then Edit .Make your alterations, then select Save.
Delete a comment
While you can see other reviewers' comments, you can only delete your own comments.
In the Side paneselect the comment you want to delete.
Select the More options button, then Delete.
Confirm by selecting Delete again.
Reply to others' comments
You can reply to comments other reviewers have inserted into the component.
In the Side pane select the comment you want to post a reply to.
In the Reply text field, enter your reply.
TipYou can mention other users in your comments and Paligo will send them a notification message.
To mention them, enter @ followed by the first characters of their name. Paligo then displays a list and you can select the user from the list.
Select Reply to post your reply.
View resolved comments
You can view all resolved comments pertaining to the component you're working on. This can be especially useful when a component has been sent out to multiple reviewers. You can see all resolved comments in the Side pane, selecting the Resolved button.
Finish the assignment
Once you are done with your assignment, you can file it away as completed or indicate that more work needs to be done. The author is then notified that you are done with your part.
Select the Assignments button.
Select either Needs work, or Approve.
NoteThese actions can also be undone if you want to continue working on the assignment.
Generate previews
You can generate previews for components in Edit view in the following formats: HTML, HTML5 and PDF.
The preview will only be generated for the component currently in Edit view. You cannot generate a preview for components in Read-only view.
For example, if you have a publication with several components open in the Next-Gen Editor, the preview generated will only show the component currently in Edit view.
Make sure you have the correct component open in Edit view by selecting its Edit button.
Set the correct layout for your preview by selecting Preview, then Preview settings. In the Preview tab, select the correct layout for the output format you want to generate.
If required, set the correct variables and profiling settings by selecting Preview, then Profiling settings. Select the correct variables and profiling.
Select Preview, then select the output format you want to generate (HTML; HTML5 or PDF). The preview will be generated in a new browser tab.
Icons and keyboard shortcuts
Paligo has many keyboard shortcuts, to make working with structured content as fast and efficient as possible. The action of a key combination depends on the context, as described below.
You can check what the current element is in the Element structure menu in the Menubar. The last element in the hierarchical path is the current element.

Almost all of the Toolbar commands can be activated with shortcuts.

It's possible to have browser plug-ins that clash with the keyboard shortcuts that Paligo uses.
If a keyboard shortcut does not work, try to remove or disable the browser plug-ins. Alternatively, try to use a different browser without plugins.
Keyboard shortcuts
Functionality | Mac | Windows | Description |
|---|---|---|---|
Copy | Command ⌘ + C | Ctrl + C | Copy text or inline elements |
Cut | Command ⌘ + X | Ctrl + X | Cut text or inline elements |
Paste | Command ⌘ + V | Ctrl + V | Paste text or inline elements |
Copy element | N/A | N/A | To copy an entire element, use the copy function in the Element context menu |
Cut element | Option ⌥ + X | Alt + X | Cut entire element |
Paste element | Option ⌥ + V | Alt + V | Paste entire element |
Paste as reuse | Option ⌥ + Shift‹ + V | Alt + Shift ⇧ + V | Paste the copied element (e.g. |
Delete | Option ⌥ + Shift ⇧ + D | Alt + Shift ⇧ + D | Delete the entire element |
Bold | Command ⌘ + B | Ctrl + B | Toggles bold formatting |
Italic | Command ⌘ + I | Ctrl + I | Toggles italic formatting |
Underline | Command ⌘ + U | Ctrl + U | Toggles underline formatting |
Clear formatting | Option ⌥ + Shift ⇧ + F | Alt + Shift ⇧ + F | Clear all existing formatting from the selected text |
Unordered list | Option ⌥ + L | Alt + L | Creates or converts existing list to an unordered list |
Ordered list | Option ⌥ + Shift ⇧ + L | Alt + Shift ⇧ + L | Creates or converts existing list to an ordered list |
Procedure | Option ⌥ + Shift ⇧ + P | Alt + Shift ⇧ + P | Creates or converts existing list to a procedure |
Todo list | Command ⌘ + Option ⌥ + Shift ⇧+ C | Ctrl + Alt + Shift ⇧+ C | Creates or converts existing list to todo list |
Link | Option ⌥ + R | Alt + R | Inserts a cross-reference |
Variable | Option ⌥ + Shift ⇧ + I | Alt + Shift ⇧ + I | Inserts a variable |
Table | Option ⌥ + Shift ⇧ + A | Alt + Shift ⇧ + A | Insert a table |
Column | Option ⌥ + Control ^ + → | Alt + Ctrl + → | Inside a table, insert a column to the right of the current cell |
Row | Option ⌥ + Control ^ + ↓ | Alt + Ctrl + ↓ | Inside a table, insert a row below the current cell |
Merge | Option ⌥ + M | Alt + M | With cells selected, merge the cells |
Split | Option ⌥ + Shift ⇧ + M | Alt + Shift ⇧ + M | With a cell selected, split the cell into two cells |
Image | Control ^ + Option ⌥ + I | Alt + Ctrl + I | Insert an image |
Side by side image | Option ⌥ + J | Alt + J | Inserts a side-by-side image. Choose an image from the image browser. |
Thumbnail | Option ⌥ + Shift ⇧ + Q | Alt + Shift ⇧ + Q | Toggles an existing image to or from a thumbnail |
Note | Option ⌥ + Shift ⇧ + N | Alt + Shift ⇧ + N | Inserts a note |
Warning | Option ⌥ + Shift ⇧ + W | Alt + Shift ⇧ + W | Inserts a warning |
Caution | Option ⌥ + Shift ⇧ + C | Alt + Shift ⇧ + C | Inserts a caution |
Tip | Option ⌥ + Control ^ + T | Alt + Ctrl + T | Insert a tip |
Element insert menu | Command ⌘ + Enter | Ctrl + Enter | Shows the Element insert menu. Use Esc to leave. |
Next cell | Tab | Tab | Inside a table, move to next cell |
Previous cell | Shift ⇧ + Tab | Shift ⇧ + Tab | Inside a table, move to previous cell |
Element navigation | Arrow keys | Arrow keys | Move between elements |
Element up | Option ⌥ + Shift ⇧ + ↓ | Alt + Shift ⇧ + ↓ | Move the current element up |
Element down | Option ⌥ + Shift ⇧ + ↑ | Alt + Shift ⇧ + ↑ | Move the current element down |
Save | Command ⌘ + S | Ctrl + S | Save the component open in Edit mode |
Undo | Command ⌘ + Z | Ctrl + Z | Undo the last action |
Redo | Command ⌘ + Y | Ctrl + Y | Redo the last action |
Code | Option ⌥ + . | Alt + . | Convert to program listing or code element |
Tag | Option ⌥ + E | Alt + E | Toggle or convert to tag (HTML or XML tag) |
Guilabel | Option ⌥ + G | Alt + G | Toggle or convert to guilabel |
Keycap | Option ⌥ + K | Alt + K | Toggle or convert to keycap |
Toolbar icons
Icon | Shortcut Mac | Shortcut Windows | Description |
|---|---|---|---|
Command ⌘ + Z | Ctrl + Z | Undo the last action | |
Command ⌘ + Y | Ctrl + Y | Redo the last action | |
Command ⌘ + S | Ctrl + S | Save | |
N/A | N/A | Validate the document | |
N/A | N/A | More options | |
N/A | N/A | Toggle fullscreen mode | |
N/A | N/A | Insert a section at the bottom | |
Command ⌘ + B | Ctrl + B | Bold formatting | |
Command ⌘ + I | Ctrl + I | Italic formatting | |
Command ⌘ + U | Ctrl + U | Underline formatting | |
N/A | N/A | Strikethrough formatting | |
N/A | N/A | Overline formatting | |
N/A | N/A | Superscript | |
N/A | N/A | Subscript | |
N/A | N/A | Inline code (More options formatting) | |
Option ⌥ + G | Alt + G | Guilabel | |
Option ⌥ + E | Alt + E | Tag | |
Option ⌥ + L | Alt + L | Insert or convert to unordered list | |
Option ⌥ + Shift ⇧ + L | Alt + Shift ⇧ + L | Insert or convert to ordered list | |
Option ⌥ + Shift ⇧ + P | Alt + Shift ⇧ + P | Insert or convert to procedure | |
Command ⌘ + Option ⌥ + Shift ⇧+ C | Ctrl + Alt + Shift ⇧+ C | Insert or convert to todo list | |
Tab | Tab | Indent list item | |
Shift ⇧ + Tab | Shift ⇧ + Tab | Outdent list item | |
N/A | N/A | Merge list with previous one | |
N/A | N/A | Split list | |
Option ⌥ + Shift ⇧ + F | Alt + Shift ⇧ + F | Clear formatting | |
N/A | N/A | Open source code editor | |
N/A | N/A | Insert comment | |
N/A | N/A | Accept or reject suggestions |
Contribute in Next-Gen Editor
When opening a contribution assignment in the Next-Gen Editor, the topic or publication that has been assigned to you will open in Edit mode. You can then add or remove content, as well as leave comments and create review assignments.
Start contribution
If the topic you want to make changes to is in Read-only view, you need to open it up for editing before you can start working on it.
Locate the topic you want to contribute to.
Select the Edit/Close edit button
.
Start editing.
View the content structure
Some topics, and most publications can consist of many reused topics and other elements. To get an overview of the structure of the document you are contributing to, do the following:
Select the Content structure pane button
.
The Content structure pane expands and shows all reused and structure reused components.
Insert new topics in a Contribution
You can add new topics to topics or publications you are contributing to.
In between two topics or at the end of the topic you are contributing to, select the Create topic icon.
In the Create topic dialog, enter a title for the topic.
Select Create.
Select the Edit button
for the newly inserted topic to start adding content.
When adding a new topic to a topic, it will be inserted as Structure reuse.
Commenting in Contributor mode
Whether you are working in Edit or Suggestion mode, you can always insert comments into the content.
Inserting comments works in the same way it does for Reviewers. Please see Review in Next-Gen Editor for more information.
Working with assignments
While in Contributor mode, you can interact with assignments using the Assignments button in the Editor header.
Create a review assignment
If you want your contributions to be reviewed by someone other than the original assigner, you can create a review assignment.
You can only create a review assignment for the document you are currently working in.
Select the Assignments button
.
In the assignments dialog, select the Create review assignment button.
In the Create a review assignment dialog, set the following parameters:
One or more assignees
Assignment date
NoteBy default this is set to 7 days from the current date.
Assignment description (optional)
Select Create.
Finish an assignment
To finish an assignment:
Select the Assignments button
.
In the assignments dialog, select the Finish assignment button.
NoteThis action can be undone by selecting the Undo button.
Switch to another assignment
You can switch to any other assignment that is currently assigned to you.
Select the Assignments button
.
In the assignments dialog, select the title of the assignment you want to switch to.















































